You are here

9 posts / 0 new
Last post
Luminar not showing as editing Extension in Apple Photos #1
Thomas Emmerich's picture
by Thomas Emmerich
November 26, 2016 - 2:52pm

Thomas

Thomas Emmerich's picture
by Thomas Emmerich
November 26, 2016 - 3:02pm

Not sure what happened to my previous post text. All that shows is the title.

Luminar doesn’t show up as an editing extension nor in the System Preferences Extensions panel.

I’m running MacOS 10.12.1 and Luminar 1.0.1. Any ideas?

Thomas

AHolmes's picture
by AHolmes
November 26, 2016 - 10:33pm

Hi Thomas,

Not sure what to suggest. I am running the same versions of macOS and Luminar, but am not having a problem using Luminar as an extension of Photos.

 

Andrew

Yoav from Picktorial's picture
by Yoav from Picktorial
November 28, 2016 - 10:51am

I would try to uninstall using App Cleaner (free download from here), reinstall to the Applications folder, open the standalone app once and try again to add the Photos extension in the system preferences panel.

Picktorial can natively browse Aperture libraries and provides powerful non-destructive editing tools.
www.picktorial.com

Thomas Emmerich's picture
by Thomas Emmerich
November 28, 2016 - 9:49pm

Thanks for the responses. I have contacted MacPhun support and they suggested the same steps as Yoav. I removed Luminar using AppCleaner and reinstalled it. No success.

Oddly, it works as an extension in my two other accounts on this Mac. Just not on “my” account.

There’s got to be some corrupt file in my user account preventing it from working. All my other MacPhun apps work fine as well as other photo apps.

Thomas

Thomas Emmerich's picture
by Thomas Emmerich
December 7, 2016 - 8:07am

An update to my issue: Solved!

The steps provided by MacPhun support never did end up working. But I tried my own step of running the Maintenance tools inside of Onyx. I did two of the options under Maintenance so I don’t know which one actually fixed my problem. The fix permissions option was a likely candidate.

I had previously run the Clean options in Onyx without results. This option cleans out various user and system caches.

Thomas

Pelyma's picture
by Pelyma
December 20, 2016 - 3:52am

Hi Thomas, I’m having exactly the same problems, what tools did you run on Onyx?

Thanks

Thomas Emmerich's picture
by Thomas Emmerich
December 20, 2016 - 1:42pm

I think the fix was the permissions fix under the Maintenance section.

Thomas

Pelyma's picture
by Pelyma
December 21, 2016 - 4:45am

Thanks Thomas, Macphun have taken me through some other routes and the final one worked! Great service from Macphun they really went the extra mile.

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive and must be updated every 90 days - Forgot your password?

Or log in with...

© 2017 PhotoApps.Expert All rights reserved.
randomness